logo de codeigniter hd

Mise à jour de Codeigniter

La mise à jour de codeigniter 2.2.0 est disponible et elle corrige des failles de sécurités. Elle est accessible pour tous ici. Je vous invite fortement à mettre à jour votre framework car la procédure est triviale.

(copier le dossier « system » contenu dans l’archive pour remplacer celui de votre projet.)

Cela dit en passant, la version 3.0 de Codeigniter est elle aussi disponible, pour les nouveau projets je me tâte à l’utiliser car de nouvelle fonctionnalités sont présentes et bien utiles.

je m’auto plagie avec ce copier collé depuis le forum codeigniter-france.fr où j’ai lancé le sujet :

  • Intégration de composer
  • PHPUnit
  • support de l’ipv6
  • Ajout de la possibilité d’exclure des pages de la protection contre les failles CRSF
  • Ajout de la possibilité d’avoir des controllers dans des sous-dossier
  • Fin du support de PHP 5.1.6 CodeIgniter requiers >= PHP 5.2.4
  • Le driver ‘mysql est déprécié au profit de MySQLI
  • MySQLi a besoin de MySQL version >= 5.1

@ bientôt

 

 

 

Laisser un commentaire

Ce site utilise Akismet pour réduire les indésirables. En savoir plus sur comment les données de vos commentaires sont utilisées.